jcommon incompatability

A discussion forum for the JCommon class library.

jcommon incompatability

Postby arumugam » Fri Aug 18, 2006 11:41 am

jfree chart-0.9.21 + jfreereport-0.8.7-5 + jcommon 1.0.5 or 0.9.6

is failing .i understand the problem is jcommon incompatability between pre1.0.0 and post 1.0.0 jcommon releases.

my reqiirement is that
jfree chart has been integreted in the application
jfree report needs to be used...

is there any version of jfree report that uses jcommon 0.9.6 or is upgrading jfree chart the only way. please help . ..
arumugam
 
Posts: 2
Joined: Fri Aug 11, 2006 8:09 am
Location: Bangalore

Postby david.gilbert » Fri Aug 18, 2006 11:52 am

I think you are probably best to try to upgrade to the latest version of JFreeChart, which works with any version of JCommon from 1.0.0 onwards. This is a pain, I know, because of the API changes...but once you have JFreeChart 1.0.x, future updates should be easy.
David Gilbert
JFreeChart Project Leader

:idea: Read my blog
:idea: Ask your company to buy the JFreeChart Developer Guide
:idea: Check out other products sold by my company Object Refinery Limited
david.gilbert
JFreeChart Project Leader
 
Posts: 11654
Joined: Fri Mar 14, 2003 10:29 am

Re: jcommon incompatability

Postby halissonmartins » Fri Jul 17, 2009 8:11 pm

Hi, I'm using jboss-3.2.5, jfreechart-1.0.10 and jcommon-1.0.13, them having the same exception.

I allread looked this post, so I decide to search if I have another Jar in the classpath.
In my search, I found another Jars in console-mgr.sar (jfreechart.jar - 1.0, jcommon.jar - 1.0).

I'm thinking that those Jars in console-mgr.sar are having conflict whith the Jars in my aplication, but I'm not sure if I must have to remove the console-mgr.sar of my Jboss to resove this problem.

Someone can help-me?
halissonmartins
 
Posts: 2
Joined: Fri Jul 17, 2009 6:34 pm


Return to JCommon

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron